Yarn: ошибка There are no scenarios

Конфликт версий

Настройки отображения темы Показывать по сообщений с сортировкой .
Выводить , отправленные .
Одна страница
Распечатать
4X_Pro
Создатель сайта
Всего сообщений: 3597
Зарегистрирован: 9 дек. 2015 г., 19:20
Рейтинг пользователя: 1776

0
. Редактировалось 2 раза, последний — #1
Сегодня столкнулся с тем, что в Debian 12 yarn выдал ошибку:
ERROR: There are no scenarios; must have at least one.
Стал разбираться, в чём дело. Оказывается, в составе пакета cmdtest есть то ли очень древняя версия yarn, то ли другая утилита с таким же именем. Решить эту проблему можно следующим образом: установить yarn через npm:
npm -g install yarn
И дальше запускать его с полным путём:
/usr/local/bin/yarn
Другой вариант — вовсе удалить пакет cmdtest, так как он обычно требуется только тем, кто тестирует cli-приложения или скрипты.

Ребята, давайте жить спокойно!

Одна страница
Распечатать

У вас нет прав для отправки сообщений в эту тему.

Задать вопрос

Здесь можно задать мне вопрос или спросить совета по любой теме, затронутой в блогах или на форуме. После того, как я отвечу, вопрос и ответ появятся в соответствующем разделе. Но не забываем, что я — сторонник slow life, поэтому каких-либо сроков ответов не обещаю. Самые интересные вопросы станут основой для новых тем на форуме или записей в блоге.
Сразу предупреждаю: глупости, провокации, троллинг и тому подобное летит прямо в /dev/null.