Модуль ifupdown-pre сильно замедляет загрузку

Настройки отображения темы Показывать по сообщений с сортировкой .
Выводить , отправленные .
Одна страница
Распечатать
4X_Pro
Создатель сайта
Всего сообщений: 3644
Зарегистрирован: 9 дек. 2015 г., 19:20
Рейтинг пользователя: 1799

0
#1
За что отвечает unit systemd ifupdown-pre.service? У меня он стал вызывать задержку загрузки в целых 8 секунд на новом компьютере (и где-то секунду на старом). Можно ли его отключить без последствий или отложить запуск, сделав его после graphical target?

Ребята, давайте жить спокойно!

4X_Pro
Создатель сайта
Всего сообщений: 3644
Зарегистрирован: 9 дек. 2015 г., 19:20
Рейтинг пользователя: 1799

0
#2
Выяснил, в чём тут дело. Из-за каких-то багов Debian testing нормально не инициализируется WiFi. Из-за этого и такой простой. Сначала думал, дело в firmware, скачал самый новый с git.kernel.org, но без толку: для нужных файлов происходит ошибка загрузки -22 на файлах so-a0-hr-b0-64.ucode и so-a0-hr-b0-68.ucode.
Проверил на Manjaro — там всё работает как надо. Попытался взять firmware оттуда, теперь грузится файл so-a0-hr-b0-71.ucode, вроде без ошибок, но потом возникает другая:
Failed to start RT ucode: -110 Failed to run INIT ucode: -110

Ребята, давайте жить спокойно!

4X_Pro
Создатель сайта
Всего сообщений: 3644
Зарегистрирован: 9 дек. 2015 г., 19:20
Рейтинг пользователя: 1799

0
#3
Продолжаю разбираться. Вычитал, что если выгрузить модули iwlmvm iwlwifi mac80211 cfg80211 и загрузить обратно вручную, WiFi начинает работать. Проверил — это действительно так. Но чем вызвана проблема с начальной загрузкой — непонятно. Единственный плюс — убедился, что дело не в самой прошивке.

Ребята, давайте жить спокойно!

4X_Pro
Создатель сайта
Всего сообщений: 3644
Зарегистрирован: 9 дек. 2015 г., 19:20
Рейтинг пользователя: 1799

0
#4
Нашёл, в чём проблема. До того, как я разобрался с прошивками, я вычитал где-то совет прописать в modprobe.d файл, где для модуля iwlwifi параметр enable_ini прописывался в N (что соответствует нулю). Именно это и приводило к тому, что прошивка не запускалась. Когда я стал указывать этот параметр вручную в ком. строке ядра с ненулевым значением, всё заработало как надо. Потом вспомнил про этот файл, удалил его, теперь всё снова работает как надо.

Ребята, давайте жить спокойно!

Одна страница
Распечатать

У вас нет прав для отправки сообщений в эту тему.

Задать вопрос

Здесь можно задать мне вопрос или спросить совета по любой теме, затронутой в блогах или на форуме. После того, как я отвечу, вопрос и ответ появятся в соответствующем разделе. Но не забываем, что я — сторонник slow life, поэтому каких-либо сроков ответов не обещаю. Самые интересные вопросы станут основой для новых тем на форуме или записей в блоге.
Сразу предупреждаю: глупости, провокации, троллинг и тому подобное летит прямо в /dev/null.