О роутере WL-520GU

Опыт его прошивки

Настройки отображения темы Показывать по сообщений с сортировкой .
Выводить , отправленные .
Одна страница
Распечатать
4X_Pro
Создатель сайта
Всего сообщений: 3355
Зарегистрирован: 9 дек. 2015 г., 19:20
Рейтинг пользователя: 1600

0
. Редактировалось 1 раз, последний — #1
Восстановил свой старый роутер WL-520GU. В нём слетала прошивка, и при загрузке начинал мигать индикатор POWER. Сделал перепрошивку через tftp: подключил роутер к сетевому разъёму, поставил на компьютере вручную адрес 192.168.1.10 командой
sudo ip addr add 192.168.1.10/24 dev enp0s25
и дальше отправил прошивку командой
tftp 192.168.1.1 -m binary -c put WL520gu_7.0.1.45_RU.trx
Потом выждать минут 10 и перезагрузить роутер по питанию. Подробнее можно почитать тут: http://www.skillz.ru/dev/m1sc/article-Ozhivlyaem_router_asus_wl520gc_umershchvlennyi_neudachnym_proshivaniem.html
Причём получилось только с четвёртого раза! Оказывается, в Linux tftp по умолчанию передаёт данные не в binary mode, а в текстовом, и прошивка искажалась при передаче!
Теперь разбираюсь, как сделать из него повторитель для дачи.

Ребята, давайте жить спокойно!

Одна страница
Распечатать

У вас нет прав для отправки сообщений в эту тему.

Задать вопрос

Здесь можно задать мне вопрос или спросить совета по любой теме, затронутой в блогах или на форуме. После того, как я отвечу, вопрос и ответ появятся в соответствующем разделе. Но не забываем, что я — сторонник slow life, поэтому каких-либо сроков ответов не обещаю. Самые интересные вопросы станут основой для новых тем на форуме или записей в блоге.
Сразу предупреждаю: глупости, провокации, троллинг и тому подобное летит прямо в /dev/null.